Mirasys Intégration
Résumé de l’intégration
Partenaire VMS | Produit | Version | Dernière version BriefCam testée | Niveau d’intégration | Prise en charge de H.265 | Licence Supplémentaire Requise |
Mirasys | Mirasys VMS V9 | 9.9.2 | 2025 R1 (y compris moteur classique et moteur Next-Gen) | Intégration client (L3) | Oui | Oui. Demandez une licence VMS à Mirasys avec la fonctionnalité « BriefCam » activée. |
Ports Requis
Les ports suivants doivent être disponibles lors de l’installation du plugin.
Numéro de port par défaut | Description |
9000 | Port VMS Le port peut être modifié dans le VMS et dans le fichier |
8083 | Port API des alertes. Le port peut être modifié dans le VMS et dans le |
7001 et supérieure | Les caméras sont chacune équipées d’un port d’une plage supérieure à 7 000. Ces ports peuvent être modifiés et sont reflétés dans le fichier |
Installer le plugin Mirasys et vous connecter au VMS
Installer
BriefCamMirasys9Plugin_<version number>.exe.
Une fois l’installation terminée, ouvrez le BriefCam Administrator Console.
Dans le BriefCam Administrator Console, ouvrez la section Camera Management (Gestion des caméras).

Cliquez sur le bouton Add directory (Ajouter un répertoire).
Dans le champ Video Integration, sélectionnez Mirasys Integration
Dans le champ Directory Name (Nom du répertoire), saisissez un nom.
Remplissez les champs Adresse, Nom d’utilisateur et Mot de passe.
Cliquez sur Ajouter.
Mirasys Paramètres dans BriefCam

Le fichier BriefCam.MirasysIntegration.ini (situé par défaut à C:\Program Files\BriefCam\BriefCam Server\plugins) comprend les paramètres suivants :
Paramètre | Description |
| Délai d’expiration général pour la connexion VMS en secondes. |
| Port par défaut de la connexion VMS. |
| Port par défaut de l’API de déclenchement des alarmes du VMS. |
| Définit le comportement par défaut du certificat SSL de confiance. |
| Chemin d’accès au fichier |
| Comme la récupération est un flux continu, ce paramètre définit un écart maximum en secondes entre deux horodatages. Si ce seuil est atteint, un nouveau fichier d’enregistrement sera créé. |
| Ceci est utilisé lorsque les flux en direct proviennent avec un retard du VMS. |
| Ceci est utilisé pour définir les images nécessaires au réchauffement du flux. |
| Pour utiliser les flux RTSP, définissez ce paramètre sur |
| Configuration de l’utilisateur RTSP dans les paramètres de diffusion du serveur RTSP du VMS. |
| Mot de passe de l’utilisateur RTSP. |
Configuration de la diffusion vidéo en direct
Il existe deux options pour la diffusion en direct à partir du VMS :
SDK streams - Les flux en direct SDK sont prêts à l’emploi et ne nécessitent aucune configuration.
Flux RTSP - option préférée pour les règles RESPOND. Les flux RTSP doivent être activés dans le fichier ini de l’intégration, comme décrit dans la section ci-dessus, et dans le VMS, comme décrit dans la section ci-dessous.
Paramètres RTSP du VMS
Accédez à VMS Server -> Cameras -> RTSP Server Streaming.
Cochez la case Activé pour chaque caméra qui utilisera les flux RTSP.
Créez un nouveau fichier et nommez-le
MirasysCamerasMap.json. Ce fichier sera utilisé pour mapper les caméras à leur flux en direct.Remplissez la liste des caméras et de leurs flux RTSP.
Chaque caméra est son propre objet dans la liste des caméras et possède deux propriétés : le nom de la caméra et l’URL du flux en direct.

L’URL du flux en direct est copiée depuis la page RTSP du VMS.

Configuration des alertes
Pour configurer les alertes, vous devez créer manuellement un déclencheur et configurer une alarme pour chaque caméra.
Dans System Manager, allez dans Serveurs VMS -> Déclencheurs d’alarme, activez l’API de déclenchement d’alarme et créez un déclencheur d’alarme générique pour chaque caméra avec le même nom que celui de la caméra.

Allez dans Serveurs VMS -> Alarmes et configurez une alarme pour chaque déclencheur. Sélectionnez le déclencheur correspondant et configurez les actions. Activez la visibilité des alarmes pour le(s) profil(s).

Consultez les alertes dans l’application Spotter
Pour voir les alertes dans l’application client, allez dans View -> Alarms et cliquez sur Show (Afficher).

Vous verrez l'onglet Alarmes sur le côté droit de l’application client.

Mirasys Installation du client intégré
La section suivante décrit l’installation et la configuration qui doivent être effectuées pour permettre à l’application client Web BriefCam de s’intégrer dans l’application Mirasys Spotter .
Après avoir installé le plugin Mirasys sur le BriefCam Web, vous êtes prêt à installer le Mirasys Embedded Client.
Sur le même ordinateur où l’application Mirasys Spotter est installée, exécutez l’installation du plugin d’intégration intégrée en cliquant avec le bouton droit de la souris sur le
BriefCamMirasys9EmbeddedPlugin_<Version_number>.exed’installation et en sélectionnant Run as administrator (Exécuter en tant qu’administrateur).Notez que si vous utilisez la dernière mise à jour de Windows et qu’une alerte Windows Defender apparaît, cliquez sur le lien Plus d’infos et cliquez sur Exécuter quand même.

Après une installation réussie du plugin, l’emplacement du plugin peut être vérifié dans le fichier
pluginConfig.xml. Ce fichier se trouve à l’adresse suivante :C:\Users\<Current user>\AppData\Roaming\DVMS\DVR Application.
Les journaux du Mirasys Embedded Client se trouvent à l’adresse suivante : C:\Users\<Current user>\AppData\Roaming\DVMS\DVR Application\Logs\SpotterLog.txt.
Configurez l’adresse Web du client intégré
L’adresse BriefCam doit être configurée pour que le client intégré fonctionne.
Dans le Spotter, ouvrez : Fichier -> Paramètres.

Dans l'onglet Plugins, sélectionnez BriefCam Synopsis et modifiez l'adresse du client pour qu’il pointe vers BriefCam.
Une fois la configuration terminée, lorsque vous ouvrez l’application Mirasys Spotter , la page de connexion de BriefCam s’affiche.
