Skip to main content

BriefCam VMS Integration Guide

Mirasys Integration

Zuletzt aktualisiert: 4 Minuten Lesezeit
SpracheDeutsch

Integrationszusammenfassung

VMS Partner

Produkt

Version

Zuletzt getestete BriefCam Version

Integrationsstufe

H.265-Unterstützung

Zusätzliche Lizenz erforderlich

Mirasys

Mirasys VMS V9

9.9.2

2025 R1 (einschließlich Classic und Next-Gen Engine)

Client-Integration (L3)

Ja

Ja. Fordern Sie eine VMS-Lizenz bei Mirasys an, bei denen die Funktion "BriefCam" aktiviert ist.

Erforderliche Ports

Folgende Ports sollten bei der Installation des Plugins verfügbar sein.

Standard-Port #

Beschreibung

9000

VMS-Port. Der Port kann im VMS und in der BriefCam.MirasysIntegration.ini geändert werden.

8083

Warnungen API-Port. Der Port kann im VMS und in der BriefCam.MirasysIntegration.ini

7001 und neuer

Die Kameras verfügen jeweils über einen Port aus dem Bereich über 7000. Diese Ports können geändert werden und werden in der MirasysCamerasMap.json -Datei angezeigt.

Installieren des Mirasys -Plugins und Verbinden mit dem VMS

  • Installation von BriefCamMirasys9Plugin_<version number>.exe.

  1. Öffnen Sie nach Abschluss der Installation das BriefCam Administrator Console.

  2. Öffnen Sie im BriefCam Administrator Consoleden Abschnitt Camera Management.

    Camera Management full screen.png
  3. Klicken Sie auf die Schaltfläche Verzeichnis hinzufügen.

  4. Wählen Sie im Feld Videointegration die Option Mirasys Integration

  5. Geben Sie in das Feld Verzeichnisname einen Namen ein.

  6. Füllen Sie die Felder Adresse, Benutzername und Passwort aus.

  7. Klicken Sie auf Hinzufügen.

Mirasys Einstellungen in BriefCam

Mirasys config file.png

Die BriefCam.MirasysIntegration.ini -Datei (die sich standardmäßig unter C:\Program Files\BriefCam\BriefCam Server\pluginsbefindet) enthält die folgenden Einstellungen:

Einstellung

Beschreibung

ConnectionTimeoutSec

Allgemeine Zeitüberschreitung für VMS-Verbindung in Sekunden.

DefaultPort

Standard-Port der VMS-Verbindung.

AlertsPort

Standard-Port der VMS Alarm Triggering API.

TrustAllCertificates

Legt das Standardverhalten für das Vertrauen in SSL-Zertifikate fest.

FFmpegPath

Der Pfad zur ffmpeg.exe Datei. Der Abruf sowohl für kontinuierliche Aufzeichnungen als auch für Aufzeichnungen zur Bewegungserkennung erfolgt über diese Datei.

MotionDetectionGapSec

Da das Abrufen ein fortlaufender Stream ist, definiert dieser Parameter eine maximale Lücke in Sekunden zwischen zwei Zeitstempeln. Wenn dieser Schwellenwert erreicht ist, wird eine neue Aufzeichnungsdatei erstellt.

LiveDelayMsec

Dies wird verwendet, wenn Live-Streams mit einer Verzögerung vom VMS kommen.

LiveStreamWarmupFrameCount

Dies wird verwendet, um die für die Stream-Aufwärmphase benötigten Bilder einzustellen.

Rtsp

Um die RTSP-Streams zu verwenden, setzen Sie diesen Parameter auf true.

RtspUser

RTSP-Benutzereinrichtung in den VMS RTSP Server Streaming-Einstellungen.

RtspPassword

Passwort des RTSP-Benutzers.

Einrichten von Live-Videostreaming

Es gibt zwei Optionen für das Live-Streaming vom VMS:

  1. SDK-Streams - SDK-Live-Streams funktionieren sofort und erfordern keine Einrichtung.

  2. RTSP-Streams – bevorzugte Option für RESPOND-Regeln. RTSP-Streams müssen in den VMS in der ini-Datei der Integration aktiviert werden, wie im obigen Abschnitt beschrieben, und im VMS, wie im folgenden Abschnitt beschrieben.

VMS RTSP-Einstellungen
  1. Navigieren Sie zu VMS-Server -> Kameras -> RTSP Server Streaming.

  2. Aktivieren Sie das Kontrollkästchen Aktiviert für jede Kamera, die die RTSP-Streams verwenden soll.

  3. Erstellen Sie eine neue Datei und benennen Sie sie MirasysCamerasMap.json. Diese Datei wird verwendet, um die Kameras ihrem Live-Stream zuzuordnen.

  4. Füllen Sie die Liste der Kameras und ihrer RTSP-Streams aus.

Jede Kamera ist ein eigenes Objekt in der Kameraliste und verfügt über zwei Eigenschaften: den Namen der Kamera und die URL des Live-Streams.

Mirasys streaming settings.png

Die Live-Stream-URL wird von der VMS RTSP-Seite kopiert.

Mirasys camera map.png
Konfiguration von Warnungen

Um Alarme zu konfigurieren, müssen Sie manuell einen Auslöser erstellen und für jede Kamera einen Alarm konfigurieren.

Im System Manager gehen Sie zu VMS-Server -> Alarmauslöser, aktivieren Sie die Alarmauslöser-API und erstellen Sie einen generischen Alarmauslöser für jede Kamera mit dem gleichen Namen wie der Kameraname.

Mirasys alarm triggers.png

Gehen Sie zu VMS-Server -> Alarme und konfigurieren Sie Alarme für jeden Auslöser. Wählen Sie den entsprechenden Auslöser aus und konfigurieren Sie die Aktionen. Aktivieren Sie die Alarmsichtbarkeit für Profil(e).

Mirasys alarm configuration.png
Warnungen in der Spotter-Anwendung anzeigen

Um Alarme in der Client-Anwendung zu sehen, gehen Sie zu Ansicht -> Alarme und klicken Sie auf Anzeigen.

Mirasys Spotter 1.png

Sie sehen die Registerkarte Alarme auf der rechten Seite der Client-Anwendung.

Mirasys Spotter 2.png

Mirasys Embedded Client-Installation

Im folgenden Abschnitt werden die Installation und Konfiguration beschrieben, die durchgeführt werden müssen, damit die BriefCam Web-Client-Anwendung in die Mirasys Spotter Anwendung eingebettet werden kann.

Nach der Installation des Mirasys -Plugins auf dem BriefCam -Server können Sie den Mirasys Embedded Client installieren.

  1. Führen Sie auf demselben Computer, auf dem die Mirasys Spotter Anwendung installiert ist, die Embedded Integration Plugin Installation aus, indem Sie mit der rechten Maustaste auf die BriefCamMirasys9EmbeddedPlugin_<Version_number>.exe klicken und Als Administrator ausführen auswählen.

    Hinweis: Wenn Sie das neueste Windows Update verwenden und eine Windows Defender-Warnung angezeigt wird, klicken Sie auf den Link Weitere Informationen und dann auf Trotzdem ausführen.

    Windows protected your PC4.png
  2. Nach der erfolgreichen Installation des Plugins kann der Speicherort des Plugins in der pluginConfig.xml -Datei überprüft werden. Diese Datei befindet sich unter: C:\Users\<Current user>\AppData\Roaming\DVMS\DVR Application.

    Mirasys DVR app.png

Protokolle für den Mirasys Embedded Client finden Sie unter: C:\Users\<Current user>\AppData\Roaming\DVMS\DVR Application\Logs\SpotterLog.txt.

Einrichten der Webadresse des Embedded Client

Die BriefCam-Adresse muss eingerichtet werden, damit der Embedded Client funktioniert.

  1. Öffnen Sie im Spotter: Datei -> Einstellungen.

    Mirasys video synopsis.png
  2. Wählen Sie auf der Registerkarte Plugins die Option BriefCam Synopsis und ändern Sie die Client-Adresse so, dass sie auf BriefCam verweist.

  3. Wenn Sie nach erfolgreicher Einrichtung die Mirasys Spotter Anwendung öffnen, wird die Anmeldeseite von BriefCam angezeigt.

    Mirasys BriefCam embedded.png