API Gateway doesn't answer requests

You attempt to log in in a browser application through the API Gateway. The API Gateway doesn't answer requests and log in doesn't succeed.

Symptoms

  • Your browser Developer tools Network tab shows error status 502 Bad Gateway or 503 Service Unavailable.

  • You see error events in the Windows Application log and IIS request log related to the API Gateway.

Cause

Syntax errors in the appsettings configuration files will prevent the API Gateway from starting.

Remedy

Do not edit appsettings.json manually. This file is created by the product installer and maintained by the Server Configurator.

Open and edit appsettings.production.json in a validating editor.

For more information, see Editing configuration files.